RN 0.6 以上 安装 react-native-camera 报错



  • 最近开始接触RN,在安装react-native-camera之后,项目就跑不起来了,参看官方文档及百度,看好多配置都是0.6版本之下的,按照搜索到的东西配置,试来试去项目还是跑不起来,有人能告诉我应该怎么配置文件么,以下为遇到的错误之一,Windows,Android!

    > Task :app:transformClassesWithDexBuilderForDebug FAILED
    
    Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
    Use '--warning-mode all' to show the individual deprecation warnings.
    See https://docs.gradle.org/5.4.1/userguide/command_line_interface.html#sec:command_line_warnings
    90 actionable tasks: 2 executed, 88 up-to-date
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    Execution failed for task ':app:transformClassesWithDexBuilderForDebug'.
    > com.google.gson.stream.MalformedJsonException: Invalid escape sequence at line 1 column 38 path $[0].name
    


  • 有人能告诉我应该怎么配置么,或者给个示例demo看看么,鄙人不胜感激,今天把react-native-camera卸载掉,项目才能重新跑起来,T.T


Log in to reply