react-native init waiting... 一直等待初始化不了 请大神帮看下



  • 如题,

    这是命令:

    caoMacBook-Pro:~ clj$ node -v
    v9.3.0
    caoMacBook-Pro:~ clj$ npm -v
    5.6.0
    caoMacBook-Pro:~ clj$ yarn -v
    1.3.2
    caoMacBook-Pro:~ clj$

    caoMacBook-Pro:Desktop clj$ react-native init MyApp --version 0.44.3
    This will walk you through creating a new React Native project in /Users/clj/Desktop/MyApp
    Using yarn v1.3.2
    Installing react-native@0.44.3...
    yarn add v1.3.2
    info No lockfile found.
    [1/4] 🔍 Resolving packages...
    warning react-native > connect@2.30.2: connect 2.x series is deprecated
    warning react-native > fbjs-scripts > gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
    [2/4] 🚚 Fetching packages...
    [3/4] 🔗 Linking dependencies...
    warning " > react-native@0.44.3" has unmet peer dependency "react@16.0.0-alpha.6".
    [4/4] 📃 Building fresh packages...
    success Saved lockfile.
    success Saved 470 new dependencies.
    ├─ absolute-path@0.0.0
    ├─ accepts@1.2.13
    ├─ ajv@5.5.2
    ├─ align-text@0.1.4
    ├─ ansi-escapes@1.4.0
    ├─ ansi-gray@0.1.1
    ├─ ansi-regex@2.1.1
    ├─ ansi-styles@2.2.1
    ├─ ansi-wrap@0.1.0
    ├─ ansi@0.3.1
    ├─ anymatch@1.3.2
    ├─ are-we-there-yet@1.1.4
    ├─ arr-diff@2.0.0
    ├─ arr-flatten@1.1.0
    ├─ array-differ@1.0.0
    ├─ array-filter@0.0.1
    ├─ array-map@0.0.0
    ├─ array-reduce@0.0.0
    ├─ array-uniq@1.0.3
    ├─ array-unique@0.2.1
    ├─ art@0.10.1
    ├─ asap@2.0.6
    ├─ asn1@0.2.3
    ├─ assert-plus@1.0.0
    ├─ async@2.6.0
    ├─ asynckit@0.4.0
    ├─ aws-sign2@0.7.0
    ├─ aws4@1.6.0
    ├─ babel-code-frame@6.26.0
    ├─ babel-core@6.26.0
    ├─ babel-generator@6.26.0
    ├─ babel-helper-builder-react-jsx@6.26.0
    ├─ babel-helper-call-delegate@6.24.1
    ├─ babel-helper-define-map@6.26.0
    ├─ babel-helper-function-name@6.24.1
    ├─ babel-helper-get-function-arity@6.24.1
    ├─ babel-helper-hoist-variables@6.24.1
    ├─ babel-helper-optimise-call-expression@6.24.1
    ├─ babel-helper-regex@6.26.0
    ├─ babel-helper-remap-async-to-generator@6.24.1
    ├─ babel-helper-replace-supers@6.24.1
    ├─ babel-helpers@6.24.1
    ├─ babel-messages@6.23.0
    ├─ babel-plugin-check-es2015-constants@6.22.0
    ├─ babel-plugin-external-helpers@6.22.0
    ├─ babel-plugin-react-transform@2.0.2
    ├─ babel-plugin-syntax-async-functions@6.13.0
    ├─ babel-plugin-syntax-class-properties@6.13.0
    ├─ babel-plugin-syntax-flow@6.18.0
    ├─ babel-plugin-syntax-jsx@6.18.0
    ├─ babel-plugin-syntax-object-rest-spread@6.13.0
    ├─ babel-plugin-syntax-trailing-function-commas@6.22.0
    ├─ babel-plugin-transform-async-to-generator@6.16.0
    ├─ babel-plugin-transform-class-properties@6.24.1
    ├─ babel-plugin-transform-es2015-arrow-functions@6.22.0
    ├─ babel-plugin-transform-es2015-block-scoped-functions@6.22.0
    ├─ babel-plugin-transform-es2015-block-scoping@6.26.0
    ├─ babel-plugin-transform-es2015-classes@6.24.1
    ├─ babel-plugin-transform-es2015-computed-properties@6.24.1
    ├─ babel-plugin-transform-es2015-destructuring@6.23.0
    ├─ babel-plugin-transform-es2015-for-of@6.23.0
    ├─ babel-plugin-transform-es2015-function-name@6.24.1
    ├─ babel-plugin-transform-es2015-literals@6.22.0
    ├─ babel-plugin-transform-es2015-modules-commonjs@6.26.0
    ├─ babel-plugin-transform-es2015-object-super@6.24.1
    ├─ babel-plugin-transform-es2015-parameters@6.24.1
    ├─ babel-plugin-transform-es2015-shorthand-properties@6.24.1
    ├─ babel-plugin-transform-es2015-spread@6.22.0
    ├─ babel-plugin-transform-es2015-sticky-regex@6.24.1
    ├─ babel-plugin-transform-es2015-template-literals@6.22.0
    ├─ babel-plugin-transform-es2015-unicode-regex@6.24.1
    ├─ babel-plugin-transform-es3-member-expression-literals@6.22.0
    ├─ babel-plugin-transform-es3-property-literals@6.22.0
    ├─ babel-plugin-transform-flow-strip-types@6.22.0
    ├─ babel-plugin-transform-object-assign@6.22.0
    ├─ babel-plugin-transform-object-rest-spread@6.26.0
    ├─ babel-plugin-transform-react-display-name@6.25.0
    ├─ babel-plugin-transform-react-jsx-source@6.22.0
    ├─ babel-plugin-transform-react-jsx@6.24.1
    ├─ babel-plugin-transform-regenerator@6.26.0
    ├─ babel-plugin-transform-strict-mode@6.24.1
    ├─ babel-polyfill@6.26.0
    ├─ babel-preset-es2015-node@6.1.1
    ├─ babel-preset-fbjs@2.1.4
    ├─ babel-preset-react-native@1.9.2
    ├─ babel-register@6.26.0
    ├─ babel-runtime@6.26.0
    ├─ babel-template@6.26.0
    ├─ babel-traverse@6.26.0
    ├─ babel-types@6.26.0
    ├─ babylon@6.18.0
    ├─ balanced-match@1.0.0
    ├─ base64-js@1.2.1
    ├─ base64-url@1.2.1
    ├─ basic-auth-connect@1.0.0
    ├─ basic-auth@1.0.4
    ├─ batch@0.5.3
    ├─ bcrypt-pbkdf@1.0.1
    ├─ beeper@1.1.1
    ├─ big-integer@1.6.26
    ├─ body-parser@1.13.3
    ├─ boom@4.3.1
    ├─ bplist-creator@0.0.7
    ├─ bplist-parser@0.1.1
    ├─ brace-expansion@1.1.8
    ├─ braces@1.8.5
    ├─ bser@1.0.2
    ├─ builtin-modules@1.1.1
    ├─ bytes@2.1.0
    ├─ camelcase@3.0.0
    ├─ caseless@0.12.0
    ├─ center-align@0.1.3
    ├─ chalk@1.1.3
    ├─ cli-cursor@1.0.2
    ├─ cli-width@2.2.0
    ├─ cliui@3.2.0
    ├─ clone-stats@0.0.1
    ├─ clone@1.0.3
    ├─ co@4.6.0
    ├─ code-point-at@1.1.0
    ├─ color-support@1.1.3
    ├─ combined-stream@1.0.5
    ├─ commander@2.12.2
    ├─ compressible@2.0.12
    ├─ compression@1.5.2
    ├─ concat-map@0.0.1
    ├─ concat-stream@1.6.0
    ├─ connect-timeout@1.6.2
    ├─ connect@2.30.2
    ├─ content-type@1.0.4
    ├─ convert-source-map@1.5.1
    ├─ cookie-parser@1.3.5
    ├─ cookie-signature@1.0.6
    ├─ cookie@0.1.3
    ├─ core-js@2.5.3
    ├─ core-util-is@1.0.2
    ├─ crc@3.3.0
    ├─ cross-spawn@3.0.1
    ├─ cryptiles@3.1.2
    ├─ csrf@3.0.6
    ├─ csurf@1.8.3
    ├─ dashdash@1.14.1
    ├─ dateformat@2.2.0
    ├─ debug@2.2.0
    ├─ decamelize@1.2.0
    ├─ delayed-stream@1.0.0
    ├─ delegates@1.0.0
    ├─ denodeify@1.2.1
    ├─ depd@1.0.1
    ├─ destroy@1.0.4
    ├─ detect-indent@4.0.0
    ├─ dom-walk@0.1.1
    ├─ duplexer2@0.0.2
    ├─ ecc-jsbn@0.1.1
    ├─ ee-first@1.1.1
    ├─ encoding@0.1.12
    ├─ errno@0.1.6
    ├─ error-ex@1.3.1
    ├─ errorhandler@1.4.3
    ├─ escape-html@1.0.3
    ├─ escape-string-regexp@1.0.5
    ├─ esutils@2.0.2
    ├─ etag@1.7.0
    ├─ event-target-shim@1.1.1
    ├─ exec-sh@0.2.1
    ├─ exit-hook@1.1.1
    ├─ expand-brackets@0.1.5
    ├─ expand-range@1.8.2
    ├─ express-session@1.11.3
    ├─ extend@3.0.1
    ├─ extglob@0.3.2
    ├─ extsprintf@1.3.0
    ├─ fancy-log@1.3.2
    ├─ fast-deep-equal@1.0.0
    ├─ fast-json-stable-stringify@2.0.0
    ├─ fb-watchman@1.9.2
    ├─ fbjs-scripts@0.7.1
    ├─ fbjs@0.8.16
    ├─ figures@1.7.0
    ├─ filename-regex@2.0.1
    ├─ fill-range@2.2.3
    ├─ finalhandler@0.4.0
    ├─ find-up@1.1.2
    ├─ for-in@1.0.2
    ├─ for-own@0.1.5
    ├─ forever-agent@0.6.1
    ├─ form-data@2.3.1
    ├─ fresh@0.3.0
    ├─ fs-extra@1.0.0
    ├─ fs.realpath@1.0.0
    ├─ gauge@1.2.7
    ├─ get-caller-file@1.0.2
    ├─ getpass@0.1.7
    ├─ glob-base@0.3.0
    ├─ glob-parent@2.0.0
    ├─ glob@7.1.2
    ├─ global@4.3.2
    ├─ globals@9.18.0
    ├─ glogg@1.0.0
    ├─ graceful-fs@4.1.11
    ├─ gulp-util@3.0.8
    ├─ gulplog@1.0.0
    ├─ har-schema@2.0.0
    ├─ har-validator@5.0.3
    ├─ has-ansi@2.0.0
    ├─ has-gulplog@0.1.0
    ├─ has-unicode@2.0.1
    ├─ hawk@6.0.2
    ├─ hoek@4.2.0
    ├─ home-or-tmp@2.0.0
    ├─ hosted-git-info@2.5.0
    ├─ http-errors@1.3.1
    ├─ http-signature@1.2.0
    ├─ iconv-lite@0.4.11
    ├─ image-size@0.3.5
    ├─ immutable@3.7.6
    ├─ imurmurhash@0.1.4
    ├─ inflight@1.0.6
    ├─ inherits@2.0.3
    ├─ inquirer@0.12.0
    ├─ invariant@2.2.2
    ├─ invert-kv@1.0.0
    ├─ is-arrayish@0.2.1
    ├─ is-buffer@1.1.6
    ├─ is-builtin-module@1.0.0
    ├─ is-dotfile@1.0.3
    ├─ is-equal-shallow@0.1.3
    ├─ is-extendable@0.1.1
    ├─ is-extglob@1.0.0
    ├─ is-finite@1.0.2
    ├─ is-fullwidth-code-point@1.0.0
    ├─ is-glob@2.0.1
    ├─ is-number@2.1.0
    ├─ is-posix-bracket@0.1.1
    ├─ is-primitive@2.0.0
    ├─ is-stream@1.1.0
    ├─ is-typedarray@1.0.0
    ├─ is-utf8@0.2.1
    ├─ isarray@1.0.0
    ├─ isemail@1.2.0
    ├─ isexe@2.0.0
    ├─ isobject@2.1.0
    ├─ isomorphic-fetch@2.2.1
    ├─ isstream@0.1.2
    ├─ jest-docblock@20.0.3
    ├─ jest-haste-map@20.0.5
    ├─ joi@6.10.1
    ├─ js-tokens@3.0.2
    ├─ jsbn@0.1.1
    ├─ jsesc@1.3.0
    ├─ json-schema-traverse@0.3.1
    ├─ json-schema@0.2.3
    ├─ json-stable-stringify@1.0.1
    ├─ json-stringify-safe@5.0.1
    ├─ json5@0.4.0
    ├─ jsonfile@2.4.0
    ├─ jsonify@0.0.0
    ├─ jsprim@1.4.1
    ├─ kind-of@3.2.2
    ├─ klaw@1.3.1
    ├─ lazy-cache@1.0.4
    ├─ lcid@1.0.0
    ├─ left-pad@1.2.0
    ├─ load-json-file@1.1.0
    ├─ lodash._basecopy@3.0.1
    ├─ lodash._basetostring@3.0.1
    ├─ lodash._basevalues@3.0.0
    ├─ lodash._getnative@3.9.1
    ├─ lodash._isiterateecall@3.0.9
    ├─ lodash._reescape@3.0.0
    ├─ lodash._reevaluate@3.0.0
    ├─ lodash._reinterpolate@3.0.0
    ├─ lodash._root@3.0.1
    ├─ lodash.escape@3.2.0
    ├─ lodash.isarguments@3.1.0
    ├─ lodash.isarray@3.0.4
    ├─ lodash.keys@3.1.2
    ├─ lodash.pad@4.5.1
    ├─ lodash.padend@4.6.1
    ├─ lodash.padstart@4.6.1
    ├─ lodash.restparam@3.6.1
    ├─ lodash.template@3.6.2
    ├─ lodash.templatesettings@3.1.1
    ├─ lodash@4.17.4
    ├─ longest@1.0.1
    ├─ loose-envify@1.3.1
    ├─ lru-cache@4.1.1
    ├─ makeerror@1.0.11
    ├─ media-typer@0.3.0
    ├─ merge@1.2.0
    ├─ method-override@2.3.10
    ├─ methods@1.1.2
    ├─ micromatch@2.3.11
    ├─ mime-db@1.30.0
    ├─ mime-types@2.1.17
    ├─ mime@1.6.0
    ├─ min-document@2.19.0
    ├─ minimatch@3.0.4
    ├─ minimist@1.2.0
    ├─ mkdirp@0.5.1
    ├─ moment@2.20.1
    ├─ morgan@1.6.1
    ├─ ms@0.7.1
    ├─ multiparty@3.3.2
    ├─ multipipe@0.1.2
    ├─ mute-stream@0.0.5
    ├─ negotiator@0.5.3
    ├─ node-fetch@1.7.3
    ├─ node-int64@0.4.0
    ├─ normalize-package-data@2.4.0
    ├─ normalize-path@2.1.1
    ├─ npmlog@2.0.4
    ├─ number-is-nan@1.0.1
    ├─ oauth-sign@0.8.2
    ├─ object-assign@4.1.1
    ├─ object.omit@2.0.1
    ├─ on-finished@2.3.0
    ├─ on-headers@1.0.1
    ├─ once@1.4.0
    ├─ onetime@1.1.0
    ├─ opn@3.0.3
    ├─ optimist@0.6.1
    ├─ options@0.0.6
    ├─ os-homedir@1.0.2
    ├─ os-locale@1.4.0
    ├─ os-tmpdir@1.0.2
    ├─ parse-glob@3.0.4
    ├─ parse-json@2.2.0
    ├─ parseurl@1.3.2
    ├─ path-exists@2.1.0
    ├─ path-is-absolute@1.0.1
    ├─ path-type@1.1.0
    ├─ pause@0.1.0
    ├─ pegjs@0.10.0
    ├─ performance-now@2.1.0
    ├─ pify@2.3.0
    ├─ pinkie-promise@2.0.1
    ├─ pinkie@2.0.4
    ├─ plist@1.2.0
    ├─ preserve@0.2.0
    ├─ pretty-format@4.3.1
    ├─ private@0.1.8
    ├─ process-nextick-args@1.0.7
    ├─ process@0.5.2
    ├─ promise@7.3.1
    ├─ prr@1.0.1
    ├─ pseudomap@1.0.2
    ├─ punycode@1.4.1
    ├─ qs@4.0.0
    ├─ random-bytes@1.0.0
    ├─ randomatic@1.1.7
    ├─ range-parser@1.0.3
    ├─ raw-body@2.1.7
    ├─ react-clone-referenced-element@1.0.1
    ├─ react-deep-force-update@1.1.1
    ├─ react-devtools-core@2.5.2
    ├─ react-native@0.44.3
    ├─ react-proxy@1.1.8
    ├─ react-timer-mixin@0.13.3
    ├─ react-transform-hmr@1.0.4
    ├─ read-pkg-up@1.0.1
    ├─ read-pkg@1.1.0
    ├─ readable-stream@1.1.14
    ├─ readline2@1.0.1
    ├─ rebound@0.0.13
    ├─ regenerate@1.3.3
    ├─ regenerator-runtime@0.9.6
    ├─ regenerator-transform@0.10.1
    ├─ regex-cache@0.4.4
    ├─ regexpu-core@2.0.0
    ├─ regjsgen@0.2.0
    ├─ regjsparser@0.1.5
    ├─ remove-trailing-separator@1.1.0
    ├─ repeat-element@1.1.2
    ├─ repeat-string@1.6.1
    ├─ repeating@2.0.1
    ├─ replace-ext@0.0.1
    ├─ request@2.83.0
    ├─ require-directory@2.1.1
    ├─ require-main-filename@1.0.1
    ├─ response-time@2.3.2
    ├─ restore-cursor@1.0.1
    ├─ right-align@0.1.3
    ├─ rimraf@2.6.2
    ├─ rndm@1.2.0
    ├─ run-async@0.1.0
    ├─ rx-lite@3.1.2
    ├─ safe-buffer@5.1.1
    ├─ sane@1.4.1
    ├─ sax@1.1.6
    ├─ semver@5.4.1
    ├─ send@0.13.2
    ├─ serve-favicon@2.3.2
    ├─ serve-index@1.7.3
    ├─ serve-static@1.10.3
    ├─ set-blocking@2.0.0
    ├─ setimmediate@1.0.5
    ├─ shell-quote@1.6.1
    ├─ simple-plist@0.2.1
    ├─ slash@1.0.0
    ├─ slide@1.1.6
    ├─ sntp@2.1.0
    ├─ source-map-support@0.4.18
    ├─ source-map@0.5.7
    ├─ sparkles@1.0.0
    ├─ spdx-correct@1.0.2
    ├─ spdx-expression-parse@1.0.4
    ├─ spdx-license-ids@1.2.2
    ├─ sshpk@1.13.1
    ├─ stacktrace-parser@0.1.4
    ├─ statuses@1.4.0
    ├─ stream-buffers@2.2.0
    ├─ stream-counter@0.2.0
    ├─ string_decoder@0.10.31
    ├─ string-width@1.0.2
    ├─ stringstream@0.0.5
    ├─ strip-ansi@3.0.1
    ├─ strip-bom@2.0.0
    ├─ supports-color@2.0.0
    ├─ temp@0.8.3
    ├─ throat@3.2.0
    ├─ through@2.3.8
    ├─ through2@2.0.3
    ├─ time-stamp@1.1.0
    ├─ tmpl@1.0.4
    ├─ to-fast-properties@1.0.3
    ├─ topo@1.1.0
    ├─ tough-cookie@2.3.3
    ├─ trim-right@1.0.1
    ├─ tsscmp@1.0.5
    ├─ tunnel-agent@0.6.0
    ├─ tweetnacl@0.14.5
    ├─ type-is@1.6.15
    ├─ typedarray@0.0.6
    ├─ ua-parser-js@0.7.17
    ├─ uglify-js@2.7.5
    ├─ uglify-to-browserify@1.0.2
    ├─ uid-safe@2.0.0
    ├─ ultron@1.0.2
    ├─ unpipe@1.0.0
    ├─ util-deprecate@1.0.2
    ├─ utils-merge@1.0.0
    ├─ uuid@3.0.1
    ├─ validate-npm-package-license@3.0.1
    ├─ vary@1.0.1
    ├─ verror@1.10.0
    ├─ vhost@3.0.2
    ├─ vinyl@0.5.3
    ├─ walker@1.0.7
    ├─ watch@0.10.0
    ├─ whatwg-fetch@1.1.1
    ├─ which-module@1.0.0
    ├─ which@1.3.0
    ├─ window-size@0.1.0
    ├─ wordwrap@1.0.0
    ├─ worker-farm@1.5.2
    ├─ wrap-ansi@2.1.0
    ├─ wrappy@1.0.2
    ├─ write-file-atomic@1.3.4
    ├─ ws@1.1.5
    ├─ xcode@0.9.3
    ├─ xmlbuilder@4.0.0
    ├─ xmldoc@0.4.0
    ├─ xmldom@0.1.27
    ├─ xpipe@1.0.5
    ├─ xtend@4.0.1
    ├─ y18n@3.2.1
    ├─ yallist@2.1.2
    ├─ yargs-parser@4.2.1
    └─ yargs@6.6.0
    ✨ Done in 16.73s.
    Setting up new React Native app in /Users/clj/Desktop/MyApp
    Adding React...
    yarn add v1.3.2
    [1/4] 🔍 Resolving packages...
    [2/4] 🚚 Fetching packages...
    [3/4] 🔗 Linking dependencies...
    [4/4] 📃 Building fresh packages...
    success Saved lockfile.
    success Saved 1 new dependency.
    └─ react@16.0.0-alpha.6
    ✨ Done in 2.28s.
    Adding Jest...
    yarn add v1.3.2
    [1/4] 🔍 Resolving packages...
    [2/4] 🚚 Fetching packages...
    [3/4] 🔗 Linking dependencies...
    warning " > babel-jest@22.0.4" has unmet peer dependency "babel-core@^6.0.0 || ^7.0.0-0".
    warning " > babel-jest@22.0.4" has unmet peer dependency "babel-core@^6.0.0 || ^7.0.0-0".
    [4/4] 📃 Building fresh packages...



    [1/2] ⠂ fsevents
    [1/2] ⡀ fsevents: https://fsevents-binaries.s3-us-west-2.amazonaws.com/
    [1/2] ⠈ fsevents: https://fsevents-binaries.s3-us-west-2.amazonaws.com/
    [2/2] ⠈ weak
    [-/2] ⠈ waiting...
    [-/2] ⠈ waiting...
    [3/4] 🔗 Linking dependencies...
    [1/2] ⠄ fsevents: https://fsevents-binaries.s3-us-west-2.amazonaws.com/
    [2/2] ⠄ weak
    [-/2] ⠄ waiting...
    [-/2] ⠄ waiting...
    [4/4] 📃 Building fresh packages...
    [-/2] ⠁ waiting...
    [2/2] ⠁ weak
    [-/2] ⠁ waiting...
    [-/2] ⠁ waiting...
    [-/2] ⠁ waiting...



  • 亚马逊服务器被墙



  • @晴明 翻墙之后,这个waiting走过去了 又出来一个waiting,但是程序可以跑起来了(react-native run-ios或者xcode都可以跑)

    warning Error running install script for optional dependency: "/Users/clj/.config/yarn/global/node_modules/fsevents: Command failed.\nExit code: 1\nCommand: node install\nArguments: \nDirectory: /Users/clj/.config/yarn/global/node_modules/fsevents\nOutput:\nnode-pre-gyp info it worked if it ends with ok\nnode-pre-gyp info using node-pre-gyp@0.6.39\nnode-pre-gyp info using node@9.3.0 | darwin | x64\nnode-pre-gyp info check checked for "/Users/clj/.config/yarn/global/node_modules/fsevents/lib/binding/Release/node-v59-darwin-x64/fse.node" (not found)\nnode-pre-gyp http GET https://fsevents-binaries.s3-us-west-2.amazonaws.com/v1.1.3/fse-v1.1.3-node-v59-darwin-x64.tar.gz\nnode-pre-gyp ERR! Tried to download(undefined): https://fsevents-binaries.s3-us-west-2.amazonaws.com/v1.1.3/fse-v1.1.3-node-v59-darwin-x64.tar.gz \nnode-pre-gyp ERR! Pre-built binaries not found for fsevents@1.1.3 and node@9.3.0 (node-v59 ABI, unknown) (falling back to source compile with node-gyp) \nnode-pre-gyp http tunneling socket could not be established, statusCode=503 \ngyp info it worked if it ends with ok\ngyp info using node-gyp@3.6.2\ngyp info using node@9.3.0 | darwin | x64\ngyp info ok \ngyp info it worked if it ends with ok\ngyp info using node-gyp@3.6.2\ngyp info using node@9.3.0 | darwin | x64\ngyp http GET https://npm.taobao.org/dist/v9.3.0/node-v9.3.0-headers.tar.gz\ngyp WARN install got an error, rolling back install\ngyp ERR! configure error \ngyp ERR! stack Error: tunneling socket could not be established, statusCode=503\ngyp ERR! stack at ClientRequest.onConnect (/Users/clj/.config/yarn/global/node_modules/tunnel-agent/index.js:166:19)\ngyp ERR! stack at Object.onceWrapper (events.js:254:19)\ngyp ERR! stack at ClientRequest.emit (events.js:159:13)\ngyp ERR! stack at Socket.socketOnData (_http_client.js:471:11)\ngyp ERR! stack at Socket.emit (events.js:159:13)\ngyp ERR! stack at addChunk (_stream_readable.js:265:12)\ngyp ERR! stack at readableAddChunk (_stream_readable.js:252:11)\ngyp ERR! stack at Socket.Readable.push (_stream_readable.js:209:10)\ngyp ERR! stack at TCP.onread (net.js:608:20)\ngyp ERR! System Darwin 16.7.0\ngyp ERR! command "/usr/local/Cellar/node/9.3.0_1/bin/node" "/Users/clj/.config/yarn/global/node_modules/node-gyp/bin/node-gyp.js" "configure" "--fallback-to-build" "--module=/Users/clj/.config/yarn/global/node_modules/fsevents/lib/binding/Release/node-v59-darwin-x64/fse.node" "--module_name=fse" "--module_path=/Users/clj/.config/yarn/global/node_modules/fsevents/lib/binding/Release/node-v59-darwin-x64"\ngyp ERR! cwd /Users/clj/.config/yarn/global/node_modules/fsevents\ngyp ERR! node -v v9.3.0\ngyp ERR! node-gyp -v v3.6.2\ngyp ERR! not ok \nnode-pre-gyp ERR! build error \nnode-pre-gyp ERR! stack Error: Failed to execute '/usr/local/Cellar/node/9.3.0_1/bin/node /Users/clj/.config/yarn/global/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/Users/clj/.config/yarn/global/node_modules/fsevents/lib/binding/Release/node-v59-darwin-x64/fse.node --module_name=fse --module_path=/Users/clj/.config/yarn/global/node_modules/fsevents/lib/binding/Release/node-v59-darwin-x64' (1)\nnode-pre-gyp ERR! stack at ChildProcess.<anonymous> (/Users/clj/.config/yarn/global/node_modules/fsevents/node_modules/node-pre-gyp/lib/util/compile.js:83:29)\nnode-pre-gyp ERR! stack at ChildProcess.emit (events.js:159:13)\nnode-pre-gyp ERR! stack at maybeClose (internal/child_process.js:943:16)\nnode-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:220:5)\nnode-pre-gyp ERR! System Darwin 16.7.0\nnode-pre-gyp ERR! command "/usr/local/Cellar/node/9.3.0_1/bin/node" "/Users/clj/.config/yarn/global/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp" "install" "--fallback-to-build"\nnode-pre-gyp ERR! cwd /Users/clj/.config/yarn/global/node_modules/fsevents\nnode-pre-gyp ERR! node -v v9.3.0\nnode-pre-gyp ERR! node-pre-gyp -v v0.6.39\nnode-pre-gyp ERR! not ok \nFailed to execute '/usr/local/Cellar/node/9.3.0_1/bin/node /Users/clj/.config/yarn/global/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/Users/clj/.config/yarn/glo
    [-/2] ⠂ waiting...
    [2/2] ⠂ weak
    [-/2] ⠂ waiting...
    [-/2] ⠂ waiting...
    [-/2] ⠈ waiting...



  • 这是个可选依赖,不影响运行,但影响调试



  • @晴明 这个怎么解决啊


Log in to reply