react-web start执行报错。。。(ERROR in Loader F:\REACT NATIVE\one\node_modules\react-hot-loader\index.js didn't return a function @ multi main)



  • 0_1513156847720_QQ截图20171213171743.png ;

    package.json:
    {
    "name": "one",
    "version": "0.0.1",
    "private": true,
    "scripts": {
    "start": "node node_modules/react-native/local-cli/cli.js start",
    "test": "jest"
    },
    "dependencies": {
    "react": "^16.2.0",
    "react-dom": "^16.2.0",
    "react-native": "0.51.0",
    "react-native-for-web": "^0.1.8",
    "react-native-update": "^5.0.0",
    "react-native-web": "^0.1.16",
    "react-navigation": "^1.0.0-beta.21",
    "react-web": "0.4.6"
    },
    "devDependencies": {
    "babel-jest": "21.2.0",
    "babel-loader": "^6.2.5",
    "babel-preset-react-native": "^1.9.0",
    "babel-preset-stage-1": "^6.16.0",
    "haste-resolver-webpack-plugin": "^0.2.2",
    "jest": "21.2.1",
    "json-loader": "^0.5.4",
    "react-hot-loader": "^3.1.3",
    "react-test-renderer": "16.0.0",
    "source-list-map": "^2.0.0",
    "source-map": "~0.1.34",
    "webpack": "^1.13.2",
    "webpack-dev-server": "^1.16.1",
    "webpack-html-plugin": "^0.1.1"
    },
    "jest": {
    "preset": "react-native"
    }
    }

    webpack.config.js:

    {
    "name": "one",
    "version": "0.0.1",
    "private": true,
    "scripts": {
    "start": "node node_modules/react-native/local-cli/cli.js start",
    "test": "jest"
    },
    "dependencies": {
    "react": "^16.2.0",
    "react-dom": "^16.2.0",
    "react-native": "0.51.0",
    "react-native-for-web": "^0.1.8",
    "react-native-update": "^5.0.0",
    "react-native-web": "^0.1.16",
    "react-navigation": "^1.0.0-beta.21",
    "react-web": "0.4.6"
    },
    "devDependencies": {
    "babel-jest": "21.2.0",
    "babel-loader": "^6.2.5",
    "babel-preset-react-native": "^1.9.0",
    "babel-preset-stage-1": "^6.16.0",
    "haste-resolver-webpack-plugin": "^0.2.2",
    "jest": "21.2.1",
    "json-loader": "^0.5.4",
    "react-hot-loader": "^3.1.3",
    "react-test-renderer": "16.0.0",
    "source-list-map": "^2.0.0",
    "source-map": "~0.1.34",
    "webpack": "^1.13.2",
    "webpack-dev-server": "^1.16.1",
    "webpack-html-plugin": "^0.1.1"
    },
    "jest": {
    "preset": "react-native"
    }
    }


Log in to reply