微信分享



  • 使用react-native-wx插件,打包会提示腾讯的sdk找不到class org.apache.http之类的,打包之后的apk会闪退,求解决方法,在线等,急,项目等着上线



  • 这是个难题。

    首先:react native要求最新的Android版本支持。必须 否则不让编译

    其次:找不到这个类 是因为新的编译tools和新的AndroidSDK都废弃了这个类,简而言之,google不想让你用了。对应的你需要讲之前所有依赖该包的代码都用HttpUrlConnection的方式重写。

    再次:微信sdk显然不是你能控制的,想要他支持,等吧。

    你为了支持react,间接支持了google最新buildtools的行为,导致了这些矛盾和冲突点
    很难。兄弟。


登录后回复