RN新手请教run安卓时appcompat-v7-28.0.0.aar报错问题



  • 我现在有一个项目前两天还可以运行安卓,后来重新run的时候报以下错误
    0_1567863072536_711843e7-ffc7-4218-a706-fb2fc766cb0b-image.png
    上网找了一下问题,说是版本的问题,可是我更改之后还是一样没有解决以下是我build.gradle的代码
    0_1567863176977_7b75faa0-4de1-4e16-958e-a5d24c7ff558-image.png
    0_1567863197381_be4186cd-235d-47a0-8168-4a8abe545281-image.png
    我想问题应该就是出在gradle这里,可是我不知道该怎么解决,请各路大神帮帮小弟。



  • 你指定了lib版本为27,但编译截图却显示28,那么多半是某个第三方没有取ext变量
    又说错误发生在“这两天”,那么可能这两天有升级某个第三方?

    gradle依赖的这些问题盘根错节,没有经验的话很难分析解决,需要的话可以私聊找我付费咨询



  • @晴明 是有升级过第三方,但是我又把AS包括.gradle .Android 那些全部删除 然后重新装了一次之后还是一样报这个错误,这就很纳闷了啊。