pushy bundle发生错误Error: Cannot find module '**/node_modules/react-native/local-cli/util/Config'



  • pushy bundle --platform ios发生错误

    Mac:$ pushy bundle --platform ios
    Bundling with React Native version:  0.59.4
    Error: Cannot find module '***/node_modules/react-native/local-cli/util/Config'
        at Function.Module._resolveFilename (internal/modules/cjs/loader.js:603:15)
        at Function.Module._load (internal/modules/cjs/loader.js:529:25)
        at Module.require (internal/modules/cjs/loader.js:657:17)
        at require (internal/modules/cjs/helpers.js:22:18)
        at Object.<anonymous> (***/node_modules/react-native-update/local-cli/lib/bundle.js:454:22)
        at Generator.next (<anonymous>)
        at step (***/node_modules/react-native-update/local-cli/lib/bundle.js:310:191)
        at ***/node_modules/react-native-update/local-cli/lib/bundle.js:310:361
    


  • $ pushy -v
    react-native-update-cli: 0.1.0
    react-native-update: 5.1.6
    
    $ react-native info
    info 
      React Native Environment Info:
        System:
          OS: macOS 10.14.4
          CPU: (4) x64 Intel(R) Core(TM) i5-4278U CPU @ 2.60GHz
          Memory: 806.82 MB / 8.00 GB
          Shell: 3.2.57 - /bin/bash
        Binaries:
          Node: 11.6.0 - /usr/local/bin/node
          Yarn: 1.12.3 - /usr/local/bin/yarn
          npm: 6.9.0 - /usr/local/bin/npm
          Watchman: 4.9.0 - /usr/local/bin/watchman
        SDKs:
          iOS SDK:
            Platforms: iOS 12.2, macOS 10.14, tvOS 12.2, watchOS 5.2
          Android SDK:
            API Levels: 23, 27, 28
            Build Tools: 23.0.1, 27.0.3, 28.0.2, 28.0.3
            System Images: android-23 | Intel x86 Atom, android-23 | Google APIs Intel x86 Atom, android-27 | Google Play Intel x86 Atom
        IDEs:
          Android Studio: 3.3 AI-182.5107.16.33.5199772
          Xcode: 10.2/10E125 - /usr/bin/xcodebuild
        npmPackages:
          react: 16.6.3 => 16.6.3 
          react-native: ^0.59.4 => 0.59.4 
        npmGlobalPackages:
          react-native-cli: 2.0.1
          react-native-git-upgrade: 0.2.7
          react-native-update-cli: 0.1.0
    


  • 试下最新的5.1.7版本



  • @晴明
    更新之后没问题了