pod install 错误



  • "react": "16.4.1",
    "react-native": "^0.56.0"

    podFile:

    target 'QM_React' do

    Uncomment the next line if you're using Swift or would like to use dynamic frameworks

    use_frameworks!

    Pods for QM_React

    pod 'React', :path => '../node_modules/react-native', :subspecs => [
    'Core',
    'CxxBridge', # 如果RN版本 >= 0.47则加入此行
    'DevSupport', # 如果RN版本 >= 0.43,则需要加入此行才能开启开发者菜单
    'RCTText',
    'RCTNetwork',
    'RCTWebSocket', # 调试功能需要此模块
    'RCTAnimation', # FlatList和原生动画功能需要此模块
    ]

    如果你的RN版本 >= 0.42.0,则加入下面这行

    pod 'yoga', :path => '../node_modules/react-native/ReactCommon/yoga'

    如果RN版本 >= 0.45则加入下面三个第三方编译依赖

    pod 'DoubleConversion', :podspec => '../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec'
    pod 'glog', :podspec => '../node_modules/react-native/third-party-podspecs/glog.podspec'
    pod 'Folly', :podspec => '../node_modules/react-native/third-party-podspecs/Folly.podspec'

    end

    在pod install 时报错:
    [!] CocoaPods could not find compatible versions for pod "Folly":
    In Podfile:
    Folly (from ../node_modules/react-native/third-party-podspecs/Folly.podspec)

    Specs satisfying the Folly (from../node_modules/react-native/third-party-podspecs/Folly.podspec) dependency were found, but they required a higher minimum deployment target.

    求怎么解决。



  • @lq-zhangpod install 错误 中说:

    a higher minimum deployment target.

    后面不是给你提示了么 a higher minimum deployment target.



  • @guopeng1994pod install 错误 中说:

    a higher minimum deployment target

    需将xcode版本改为最低支持9.0
    Podfile 中 platform :ios, '9.0'