react native在ios7上编不过



  • 理论上react native是能在ios7上运行的,官网给的demo也是可以在ios7上跑的。但是我在我们自己的项目中植入react native时,在deployment target设为7.0时却编不过。报错如下:
    ld: embedded dylibs/frameworks are only supported on iOS 8.0 and later (@rpath/React.framework/React) for architecture arm64
    clang: error: linker command failed with exit code 1 (use -v to see invocation)

    将deployment target改为8.0的确可以编过,但是react native不是号称可以运行于ios7么???那为何这个相关的framework又依赖于ios8??我想在ios7上运行react native该怎么做呢?请知道的大神指点我一下,谢谢!!


登录后回复