执行pushy uploadIpa是报 INVALID CALLBACK是什么原因



  • TypeError [ERR_INVALID_CALLBACK]: Callback must be a function
    at maybeCallback (fs.js:124:9)
    at Object.fs.exists (fs.js:204:3)
    at CertDownloader.pem (/Users/hugehuge/workspace/rn/huge2.0_reactNative/node_modules/cert-downloader/index.js:96:18)
    at CertDownloader.verify (/Users/hugehuge/workspace/rn/huge2.0_reactNative/node_modules/cert-downloader/index.js:131:11)
    at module.exports (/Users/hugehuge/workspace/rn/huge2.0_reactNative/node_modules/provisioning/index.js:7:10)
    at /Users/hugehuge/workspace/rn/huge2.0_reactNative/node_modules/ipa-metadata/node_modules/async/lib/async.js:731:23
    at /Users/hugehuge/workspace/rn/huge2.0_reactNative/node_modules/ipa-metadata/node_modules/async/lib/async.js:673:13
    at /Users/hugehuge/workspace/rn/huge2.0_reactNative/node_modules/ipa-metadata/node_modules/async/lib/async.js:230:13
    at _arrayEach (/Users/hugehuge/workspace/rn/huge2.0_reactNative/node_modules/ipa-metadata/node_modules/async/lib/async.js:81:9)
    at _each (/Users/hugehuge/workspace/rn/huge2.0_reactNative/node_modules/ipa-metadata/node_modules/async/lib/async.js:72:13)



  • 应该是Node版本问题,我从10.0降到8.0了



  • 我也遇到这个问题了,必须要降node版本么?



  • 使用yarn代替npm install可以兼容node10