安卓打包react-native-update缺少必要的库



  • Warning:(75, 9) warning: implicitly declaring library function 'memcmp' with type 'int (const void *, const void *, unsigned int)' [-Wimplicit-function-declaration]Information:(75, 9) include the header <string.h> or explicitly provide a declaration for 'memcmp'
    1 warning generated.
    /Users/li/Documents/doctorSystem/ios/doctor/DoctorApp/node_modules/react-native-update/android/src/main/jni/DownloadTask.c:75:9: warning: implicitly declaring library function 'memcmp' with type 'int (const void *, const void *, unsigned int)' [-Wimplicit-function-declaration]
    Information:(75, 9) include the header <string.h> or explicitly provide a declaration for 'memcmp'
    1 warning generated.

    :react-native-update:compileLint
    :react-native-update:copyReleaseLint UP-TO-DATE
    :react-native-update:compileReleaseRenderscript
    :react-native-update:generateReleaseBuildConfig
    :react-native-update:generateReleaseResValues
    :react-native-update:generateReleaseResources
    :react-native-update:mergeReleaseResources
    :react-native-update:processReleaseManifest
    :react-native-update:processReleaseResources
    :react-native-update:generateReleaseSources
    :react-native-update:incrementalReleaseJavaCompilationSafeguard
    :react-native-update:javaPreCompileRelease
    :react-native-update:compileReleaseJavaWithJavac
    :react-native-update:compileReleaseJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

    /Users/li/Documents/doctorSystem/ios/doctor/DoctorApp/node_modules/react-native-update/android/src/main/java/cn/reactnative/modules/update/UpdateModule.java:15: 错误: 程序包com.facebook.react.cxxbridge不存在
    /Users/li/Documents/doctorSystem/ios/doctor/DoctorApp/node_modules/react-native-update/android/src/main/java/cn/reactnative/modules/update/UpdateModule.java
    Error:(131, 25) 错误: 找不到符号
    符号: 类 JSBundleLoader



  • 问题已解决 update版本出错