程序包com.facebook.react.cxxbridge不存在



  • 我使用了
    1、首先尝试删除掉 android/build android/app/build node_modules/react-native-update/android/build 三个文件夹再重试
    2、再尝试更换NDK版本到r10e再重试
    这两种办法都不可以,还是报这个错误
    版本:
    "react-native": "~0.46.4",
    "react-native-update": "^4.0.6",
    ndk r10e (64-bit)

    电脑系统:windows

    0_1506492872882_QQ截图20170927141125.png



  • 找到原因了,在\node_modules\react-native\ReactAndroid\src\main\java\com\facebook\react\bridge\JSBundleLoader.java中的命名空间是package com.facebook.react.bridge,所以文档里面的com.facebook.react.cxxbridge.JSBundleLoader程序包引用是错的,手工改成com.facebook.react.bridge.JSBundleLoader就好了,好坑呀


登录后回复