百度地图控件求助!



  • 刚学没多久,但是在地图控件这部分卡住了,公司基本用的都是百度的地图控件,但是在rn里貌似只有这个react-native-baidu-map的比较新一点,按照说明配置,一直报错。

    E:\Android\work\glxm\android\app\src\main\java\com\glxm\MainApplication.java:26: 错误: 找不到符号
    new BaiduMapPackage(getApplicationContext())
    ^
    符号: 类 BaiduMapPackage
    1 个错误

    我觉得是不是BaiduMapPackage需要引用?我不懂java,所以不大明白,请各位达人赐教!



  • @gsj82918 说:

    react-native-baidu-map

    找到 E:\Android\work\glxm\android\app\src\main\java\com\glxm\MainApplication.java 文件

    你能看到一些 import 语法
    在这些 import 语法的下面添加:

    import org.lovebing.reactnative.baidumap.BaiduMapPackage;



  • 现在的错误是

    • What went wrong:
      Execution failed for task ':app:prepareGlxmReactNativeBaiduMapUnspecifiedLibrary'.

    Could not expand ZIP 'E:\Android\work\glxm\node_modules\react-native-baidu-map\android\build\outputs\aar\react-native-baidu-map-release.aar'.

    我是0.46的rn,能用百度地图吗?


登录后回复