发布新的热更新版本 报错! 先谢谢各位大神🙏



  • 已经提交了一个ipa 包,现在修改了一下代码。执行
    pushy bundle --platform ios 命令报错 在这个之前是不是需要提交一个新的ipa 包 比如说1.1.0 版本?新手搞不懂啊 。报的错是

    sunchangweideMacBook-Pro:PushyDemo suncw$ pushy bundle --platform ios
    Bundling with React Native version: 0.42.0
    Error: Cannot find module '/Users/suncw/Desktop/RN学习/PushyDemo/node_modules/react-native/local-cli/default.config'
    at Function.Module._resolveFilename (module.js:440:15)
    at Function.Module._load (module.js:388:25)
    at Module.require (module.js:468:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/Users/suncw/Desktop/RN学习/PushyDemo/node_modules/react-native-update/local-cli/lib/bundle.js:446:89)
    at next (native)
    at step (/Users/suncw/Desktop/RN学习/PushyDemo/node_modules/react-native-update/local-cli/lib/bundle.js:310:191)
    at /Users/suncw/Desktop/RN学习/PushyDemo/node_modules/react-native-update/local-cli/lib/bundle.js:310:361
    sunchangweideMacBook-Pro:PushyDemo suncw$


  • administrators

    这是个bug 很快会修复 请晚些时候更新到4.0.4版本



  • @sunnylqm 那之前别的人都是怎么更新的啊,很多人都成功的😫


  • administrators

    0.42版本的兼容问题



  • 删除node_moduleds 文件夹,重新执行 npm install



  • 哇,晕,我之前也想升级到0.42rn,就是怕会出现兼容问题,没想到还真有,感觉react-native-update很不稳定,我还是用的4.0.0的版本,现在4.0.3稳定吗,永远都别升到最新版,建议出个稳定版和开发版区分一下!不然谁敢升级啊!


登录后回复