react-web start 报错



  • ERROR in ./~/react-web/Libraries/Animated/Animated.web.js
    Module not found: Error: Cannot resolve module 'react/lib/CSSPropertyOperations' in /home/mark/WebstormProjects/test2/node_modules/react-web/Libraries/Animated
    @ ./~/react-web/Libraries/Animated/Animated.web.js 14:27-69

    ERROR in ./~/react-web/Libraries/PanResponder/injectResponderEventPlugin.web.js
    Module not found: Error: Cannot resolve module 'react/lib/EventPluginRegistry' in /home/mark/WebstormProjects/test2/node_modules/react-web/Libraries/PanResponder
    @ ./~/react-web/Libraries/PanResponder/injectResponderEventPlugin.web.js 8:25-65

    ERROR in ./~/react-web/Libraries/PanResponder/injectResponderEventPlugin.web.js
    Module not found: Error: Cannot resolve module 'react/lib/ResponderEventPlugin' in /home/mark/WebstormProjects/test2/node_modules/react-web/Libraries/PanResponder
    @ ./~/react-web/Libraries/PanResponder/injectResponderEventPlugin.web.js 9:26-67

    ERROR in ./~/react-web/Libraries/PanResponder/injectResponderEventPlugin.web.js
    Module not found: Error: Cannot resolve module 'react/lib/EventConstants' in /home/mark/WebstormProjects/test2/node_modules/react-web/Libraries/PanResponder
    @ ./~/react-web/Libraries/PanResponder/injectResponderEventPlugin.web.js 10:20-55

    ERROR in ./~/react-web/Libraries/PanResponder/injectResponderEventPlugin.web.js
    Module not found: Error: Cannot resolve module 'react/lib/ResponderTouchHistoryStore' in /home/mark/WebstormProjects/test2/node_modules/react-web/Libraries/PanResponder
    @ ./~/react-web/Libraries/PanResponder/injectResponderEventPlugin.web.js 11:32-79

    ERROR in ./~/react-web/Libraries/Utilties/setNativeProps.web.js
    Module not found: Error: Cannot resolve module 'react/lib/CSSPropertyOperations' in /home/mark/WebstormProjects/test2/node_modules/react-web/Libraries/Utilties
    @ ./~/react-web/Libraries/Utilties/setNativeProps.web.js 8:26-68



  • 我也遇到了,等解决再来。
    环境:
    "dependencies": {
    "react": "^16.0.0-beta.5",
    "react-dom": "^16.0.0",
    "react-native": "0.48.4",
    "react-web": "0.4.6"
    },
    "devDependencies": {
    "babel-jest": "^21.2.0",
    "babel-loader": "^6.2.5",
    "babel-preset-react-native": "^1.9.0",
    "babel-preset-stage-1": "^6.16.0",
    "haste-resolver-webpack-plugin": "^0.2.2",
    "jest": "^21.2.1",
    "json-loader": "^0.5.4",
    "react-hot-loader": "^3.1.1",
    "react-test-renderer": "^16.0.0-beta.5",
    "webpack": "^1.13.2",
    "webpack-dev-server": "^1.16.1",
    "webpack-html-plugin": "^0.1.1"
    },
    "jest": {
    "preset": "react-native"
    }

    ERROR in ./~/react-web/Libraries/Utilties/setNativeProps.web.js
    Module not found: Error: Cannot resolve module 'react-dom/lib/CSSPropertyOperations' in /Volumes/Company/git.project/eloan-app/webDemo/node_modules/react-web/Libraries/Utilties
    @ ./~/react-web/Libraries/Utilties/setNativeProps.web.js 8:26-68


登录后回复