项目建立后报Error while persisting cache: TransformError:求帮助



  • 此回复已被删除!


  • 删除/Users/zzx/MyProject/node_modules/react-deep-force-update/.babelrc 然后重启就解决了



  • @qinzhzen 说:

    删除/Users/zzx/MyProject/node_modules/react-deep-force-update/.babelrc 然后重启就解决了

    :heart:



  • 正好今天也碰到这个问题,分享下:
    =======
    原因:
    新版本用的是babel 6版本,可是有些依赖的库并不是这个版本,就会导致这个错,所以解决方案就是把这个所以babel删了,升级依赖。

    解决:

    1,先删除依赖包:
    
        rm -rf node_modules
        ncu -u
        npm install
    
    2,修改package.json文件 
    
        "scripts": {
          "clean:babelrc": "find ./node_modules -name react-packager -prune -o -name '.babelrc' -print | xargs rm -f",
          "postinstall": "npm run clean:babelrc"
        }


  • @hjm201 正解



  • @alex 如何做呢?求详细!



  • @alex

    我怎么没有找到babelrc.stage ,这个文件。跪求帮助0_1455019236881_2016年2月9日 08-00-22.png


  • administrators

    @spursy 所有小数点开头的文件(是.babelrc,不是babelrc.stage)都是默认隐藏的,请在命令行下用rm命令删除



  • @sunnylqm 说:

    rm命令
    已解决,谢谢!


登录后回复